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Supporting Information 1 

This document provides more detailed descriptions of some processes undertaken in the 2 

Methods section, to make it easier to recreate the model and the results produced. The processes 3 

include building the study’s finite-difference model domain in ModelMuse, generating the input files 4 

for a single MODFLOW simulation, and generating a batch file for running all the MODFLOW 5 

simulations. 6 

This study exclusively used software that is free and available for download at the addresses 7 

listed here: 8 

• ModelMuse version 3.10.0.0: 9 

https://water.usgs.gov/nrp/gwsoftware/ModelMuse/ModelMuse.html 10 

• MODFLOW-2005 version 1.12.0: https://water.usgs.gov/ogw/modflow/mf2005.html 11 

• MT3DMS version 5.3: https://hydro.geo.ua.edu/mt3d/index.htm 12 

• MODPATH version 6.0.01: https://water.usgs.gov/ogw/modpath/ 13 

• ZoneBudget version 3.01: https://water.usgs.gov/nrp/gwsoftware/zonebud3/zonebudget3.html 14 

• R version 3.4.1: https://mirrors.sorengard.com/cran/ 15 

A.1. Starting a New Project and Adding Programs 16 
Open ModelMuse and choose to “Create a new MODFLOW model”. Adding or changing geo 17 

reference data is not necessary. Specify an initial grid with 60 rows, 120 columns, and 1 layer. At this 18 

point all row and column widths are 4m. Set the “Model_Top” elevation to 2m and the “Upper 19 

Aquifer” elevation to 0m. The grid origin has coordinates of X = 0, Y = 240, and Z = 0. Before altering 20 

anything else, go to Model > MODFLOW Options, and under the Options tab change length units to 21 

meters and time units to hours. 22 

Some basic hydrologic parameters are constant throughout the domain but need to be changed 23 

from their default values. Under Data > Edit Data Sets, expand the Required > Hydrology data sets. 24 

The default values for the Active data set should be edited to “False”; Kx, Ky, and Kz should be 25 

changed to 3.5 (m/hr); and Modflow_Initial_Head should be changed to 1 (m). 26 

All MT3DMS packages and some MODFLOW functions/post-processors need to be activated 27 

before they can be used in ModelMuse. Under Model > MODFLOW Packages and Programs, the 28 

following packages should be turned on: 29 

• Boundary conditions > Specified head > CHD 30 

• Boundary conditions > Head-dependent flux > EVT 31 

• MT3DMS > BTN, ADV, DSP, SSM, GCG 32 
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• Post-processors > MODPATH, ZoneBudget 33 

In the BTN window, make sure “MT3D Version” is set to “MT3DMS” and make one mobile 34 

chemical species with no initial concentration file. In the ADV window, the “Advection solution 35 

scheme” should be set to “Standard finite-difference method (0)”. The finite-difference solver 36 

algorithm also needs to be changed to Geometric Multigrid (Solvers > GMG), to produce acceptably 37 

low (< 0.1%) discrepancies in the domain-wide water budget throughout simulations. In MODPATH 38 

> Simulation file options, “Modpath version” should be set to “6”, “ZoneArrayOption” should be 39 

checked, and “StopZone” should be set to “2”. In MODPATH > Version 6 options, 40 

“WeakSourceOption” should be set to “Stop (2)”. For ZoneBudget options, make sure “Export CSV 41 

file” and “Export CSV2 file” are both checked. 42 

Before any objects are created, the number and type of time steps used in MODFLOW and 43 

MT3DMS should be specified. Under Model > MODFLOW Time, edit the entries of the two tabs to 44 

look like Figure S1. 45 

 46 

 47 
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 48 
Figure S1. Time settings used in this model for MODFLOW (top) and MT3DMS (bottom). 49 

A.2. Creating Objects 50 
Line objects are created to hold data for the constant head (CHD) boundary conditions, the 51 

MT3DMS conservative solute, and the ZoneBudget zone representing the stream. With the “Create 52 

polyline object” tool selected, create a line with 2,400 vertices; the initial locations of the vertices do 53 

not matter. In the Object Properties window that appears after creating the line, change the object 54 

name to “CHD_stream”. In the Vertices tab of the same window, edit the x-y coordinates of the 55 

vertices so they form a sinusoidal line with the following formula: 56 

 57 

y = 15sin((x-10)*2π/40)+40              (S1) 58 

 59 

Starting at 0.1 m, the x-values should increase in 0.2 m increments. Line objects should be created 60 

in the far left and right columns of the grid, with two vertices each; name the left line “CHD_left” and 61 

the right line “CHD_right”. The y-coordinates of these lines’ vertices should be changed to 28.2 and 62 

234. Create a similar line object with two vertices in the top row of the grid, named “CHD_top”, with 63 

x-coordinates changed to 2 and 478. For the MT3DMS solute, create a line object with 100 vertices 64 

named “MT3DMS”, then edit the x-y coordinates of those vertices to follow the sinusoidal formula 65 

mentioned above. Starting at 220.1 m, the x-values should increase in 0.2 m increments. For the 66 

ZoneBudget stream zone, create a line object named “ZB_1” with 400 vertices. Edit the vertices so 67 

they follow the same sinusoidal formula in equation S1, starting at x = 200.1 and increasing in 0.2 m 68 

increments. In the Object Properties for ZB_1, go to Data Sets > Required > ZoneBudget and check 69 

“Zones”. Edit the formula for the “Zones” data set to read “1”.  The z-coordinates of each of these 70 
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objects (on the first tab in the Object Properties window) should be edited so they fully penetrate the 71 

single layer of the domain. 72 

Polygon objects are needed to hold data for the evapotranspiration (EVT) boundary condition, 73 

the ZoneBudget zone representing the area of interest, the “StopZone” area for MODPATH particles, 74 

and to designate some domain cells as active (an earlier step made all cells inactive by default). The 75 

polygons all require odd numbers of vertices because the first and last vertices of all polygons must 76 

have the same coordinates for it to be considered a closed shape. In the Object Properties window of 77 

all polygons, make sure the object sets values of enclosed and intersected cells, with a minimum cell 78 

fraction of 0 unless noted otherwise. 79 

Three of the polygon objects needed for this model have boundaries based on the sinusoidal 80 

formula from Equation S1 but set back from the stream at various distances. With the “Create polygon 81 

object” tool selected, create a polygon with 1,421 vertices and rename it “EVT”. The final x-y 82 

coordinates for the EVT polygon vertices are based on the sinusoidal formula from the previous 83 

paragraph, factoring in two setback distances from the stream: 0.4 m for the closer side of the polygon, 84 

and 30 m for the farther side. The final location of each point can be expressed as the sum of the 85 

original point’s coordinates and x and y vectors, calculated separately with: 86 

 87 

        mn(x) = 1/-(15cos((x-10)*2π/40))          (S2) 88 

        Δx = Δy/mn                      (S3) 89 

        Δy = √((d2x2)/(1+x2))         (S4) 90 

 91 

where mn is the slope of the line normal to the original sine wave at a given x value, Δx is the x vector, 92 

Δy is the y vector, and d is the setback distance. Calculating these new vertex coordinates for both 93 

setback distances, based on the coordinates for the “CHD_stream” line object for the interval x = 94 

[120.1, 359.9], will yield more than 1,421 vertices. After removing vertices with x coordinates less than 95 

120 or greater than 360, as well as the vertices that cause the polygon to overlap itself (Figure S2), it 96 

should finally have 1,421 vertices. In the Object Properties window, set a minimum cell fraction of 97 

0.75. On the MODFLOW Features tab, make sure the EVT box is checked. For the ZoneBudget zone 98 

covering the area of interest, create a polygon object with 473 vertices, called ZB_2. The vertices have 99 

coordinates identical to those used for the EVT object for the interval x = [200, 280]. Like ZB_1, this 100 

object needs the “Zones” data set turned on, this time with a data set formula of “2”. The polygon 101 

representing the “StopZone” area for MODPATH encompasses all cells in the model except for those 102 

encompassed by ZB_2. This was accomplished with a 483-vertex polygon named “MP_stop”, with 103 

setback distances of 0 and 30.4 for the interval x = [199.7, 280.3], and then additional vertices to 104 

encompass the rest of the model. In the Object Properties window, check the Data Set box for 105 
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Required > MODPATH > Modpath_Zone, then edit the formula to “2”. Finally, the object denoting 106 

active cells is a polygon named “Active” with 2,405 vertices. This polygon encompasses all the cells 107 

bounded/intersected by the 4 CHD line objects, so it uses identical vertex coordinates. Turn on the 108 

Required > Hydrology > Active data set, then edit the formula to “True”. 109 

 110 

 111 

 112 
Figure S2. Section of the outer boundary of the EVT polygon, before (top) and after (bottom) removing 113 
overlapping vertices. 114 

A.3. Adding Data to Objects 115 
The objects representing boundary conditions need additional data to function properly for the 116 

duration of a model run. The line objects using the CHD package need to be given their constant head 117 

values. With the “Edit vertex values” tool, select the furthest-upstream vertex of CHD_stream. Edit 118 

the key to “CHD_stream” and the value to 1.35. Do the same to the furthest-downstream vertex, with 119 

the same key and a value of 0.75. In the Object Properties window for CHD_stream, go to MODFLOW 120 
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Features and select the CHD package (the name, not the check box). Starting time should be set to -1 121 

and ending time to 720. For starting head, click the gray “F()” button to edit the formula. Go to 122 

Functions > Object > InterpolatedVertexValue and double-click to add it to the formula. Edit the 123 

formula so it reads in full: InterpolatedVertexValue("CHD_stream"). Copy and paste this formula 124 

into the ending head box. This process should be repeated for the other three CHD objects, with 125 

unique keys for each object. This initial model domain will represent neutral regional groundwater 126 

flow, so vertices in the furthest-upstream column (column 1) should all be given values of 1.35 and 127 

vertices in the furthest-downstream column (column 306) should be given values of 0.75. 128 

The EVT polygon object needs a full schedule of ET withdrawal rates that change between time 129 

steps. This ET schedule can be described with an equation adapted from Gomez-Velez et al. [29]: 130 

 131 

 ET(t) = �ETmax  [1−cos(wt)]
[1−cos�wtp�]

 if t ∈ [7,18]

0                              otherwise
     (S5) 132 

 133 

where t is the hour of the current daily cycle (e.g., active ET begins in the 7th hour and ends after the 134 

18th hour of every day), ETmax is the maximum daily withdrawal rate (80 mm/day for this model 135 

setup), w = 2π/td is the event frequency, tp is the time difference between the start of active ET and 136 

ETmax, and td is the full duration of active ET. To make the daily ET schedule symmetrical across a line 137 

between two time steps, tp is set to 6 hr and td is set to 13 hr. In the MODFLOW features tab of EVT’s 138 

Object Properties window, select the EVT package and increase “Number of times” to 721. The first 139 

time step (from -1 to 0) should have an ET rate of 0, and all the subsequent time steps should have 140 

ET rates determined by Equation S5. All time steps have ET surfaces of 2 m and ET depths of 2 m. 141 

A.4. Generating MODFLOW Simulation Files and a Batch File 142 
The data contained in the ModelMuse project file must be converted to the text input files used 143 

by MODFLOW, MT3DMS, MODPATH, and ZoneBudget. Some of the input files are static across all 144 

model simulations, but others must be altered to reflect the Jy/x and ETmax being used in each scenario. 145 

A list of all input files used can be found in Table S1. 146 

 147 

Table S1. Input text files needed for this study, organized by program and whether they remain static 148 

between simulations. 149 

 MODFLOW MT3DMS MODPATH ZONEBUDGET 

STATIC 

FILES 

• model.bas 

• model.dis 

• model.gmg 

• model.adv 

• model.btn 

• model.dsp 

• model.mpbas 

• model.mpn 

• model.zb_response 

• model.zb_zones 
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• model.lmt 

• model.lpf 

• model.nam 

• model.oc 

• model.gcg 

• model.mt_nam 

• model.ssm 

NON-

STATIC 

FILES 

• model.chd 

• model.evt 

   

 150 

In ModelMuse, go to File > Export > MODFLOW-2005 Input Files. Copy all the static files to a 151 

new folder called “static_files”. Copy the CHD file to a folder called “J0”, named for the neutral 152 

scenario being explored; copy the EVT file to a folder called “ET80”, named for the ETmax = 80 mm/day 153 

scenario being explored. This step of copying non-static files to new folders needs to be repeated for 154 

all 10 scenarios of Jy/x and ET, which means new versions of those files need to be created. The new 155 

CHD and EVT files can come from either editing the boundary condition objects in ModelMuse and 156 

re-exporting, or manually editing the existing files. 157 

All the files in Table S1 should now be combined in new folders, with one folder for each of the 158 

25 simulations. The names of these folders should indicate which Jy/x and ET scenarios are being 159 

represented in each simulation. In this study a script written in R (“PreProcessing.R”) generated the 160 

simulation folders; filled each folder with the appropriate versions of each needed file, based on the 161 

name of the folder; and wrote a batch file to call on MODFLOW, MT3DMS, and ZoneBudget for each 162 

simulation in turn. Running the batch file will generate the text file results needed for post-163 

processing. MODPATH is not called in the batch file because its particle tracking took longer than 164 

the time steps needed for the other programs, and therefore was simulated separately as described 165 

in Section 2.2. 166 
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